2014年8月29日金曜日

eclipseにsmarty

今後何かの役に立つかもと
EC-Cubeを使ってプログラムの勉強を始めました。

ただ、プログラムのスキルが、ほぼゼロなので、
環境を整えるだけでも苦労しています。。。。

Eclipseにsmartyのプラグイン入れる際に
少しハマったので、メモを残しておきます。

通常ではsmartyのプラグインがないのですが、
下記サイトを参考にインストールを進めました。

Eclipseでsmarty
http://www.kimurak.net/wordpress/eclipse/190/



Help-> Install New Software を選択


マニュアル通りに取得先を設定。





しかし、先に進むとエラーとなり、インストールができない


*************************
1 つ以上の必須項目が見つからないため、インストールを完了できません。
  Software being installed: Smarty Feature 0.91.0 (org.eclipse.php.smarty_feature.feature.group 0.91.0)

  Missing requirement: Smarty Feature 0.91.0 (org.eclipse.php.smarty_feature.feature.group 0.91.0) requires 'org.eclipse.php 0.0.0' but it could not be found
*************************


エラー内容を探っていると、対処法が掲載されていました

Install SmartyPDT 0.0.9.1 in Eclipse Kepler
http://stackoverflow.com/questions/17210411/install-smartypdt-0-0-9-1-in-eclipse-kepler



対処法通りJunoのリポジトリを追加


phpのみをインストールし直すので、phpで検索をかけて
プラグインを再インストール





phpの再インストール後に、再度smartyのプラグインをインストール



今度は、エラーが出ずにインストールでき、
tplファイルがちゃんと色分けされました。




ただ、このままではphpが古い状態なので、
Junoのレポジトリを無効にして、
現バージョンのレポジトリから再度 phpをインストールし直しました。







この方法が正しい方法なのかは判らないですが、
とりあえずエラーは、発生していないので、
このまま使っています。



0 件のコメント:

コメントを投稿