2015年6月23日火曜日

IPv6 IPoEでの接続(ひかり電話契約あり)

固定IPv4アドレスは、取得しておきたかったので、
既存のIPv4プロバイダーとは、契約したまま、
新たに価格が安い @nifty(上位回線JPNE) とIPv6プラスの契約。

 ちなみに、上位回線がJPNEの場合、
 IPv6は、まったくポートの制限がかかりませんが

 IPv4は、かなり広範囲でポートの制限を受けてしまい、
 ウェルノウンポートでのサーバ公開は、基本的にできない。



最終の構成図は、こんな感じです。




自宅サーバの規模で、多段ルータは不細工ですが、
以前の投稿したように、FortiGateでDHCP-PDが使えないので。。。


通信制御は、ほぼ全てFortiGateで行っているので、
Cisco2901では、ACLなどは使っていないです。


Cisco2901の設定は、基本的にはCCOに掲載されている内容で大丈夫でした。
 IPv6 インターネット接続設定例(IPv6oE方式)
 http://www.cisco.com/cisco/web/support/JP/111/1115/1115512_IPoE.html


ただ、既存のIPv4プロバイダーとPPPoEでつなぐのは、
固定IPv4アドレスが必要なサーバ達だけで、

他のPC達は、IPv4アドレスでも回線が速いIPv6プラスを使いたかったので
ルートマップなどを使って、通信経路を変えています。

あと、IPv6は、アドレスやプレフィックスを書くのが面倒臭いので、
OSPFv3を動かしています。


Cisco2901 設定抜粋
----------------------
ip domain list flets-west.jp
ip domain list iptvf.jp
ip cef
ipv6 unicast-routing
ipv6 dhcp pool DHCP-PD
 import dns-server
 import domain-name
!
ipv6 cef
!
!
interface GigabitEthernet0/0
 ip address 172.16.3.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
 pppoe enable group global
 ipv6 address autoconfig default
 ipv6 enable
 no ipv6 redirects
 ipv6 dhcp client pd PREFIX
 ipv6 ospf 1 area 0
 pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
 ip address 172.16.2.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip nat inside
 ip policy route-map PPPoE
 duplex auto
 speed auto
 ipv6 address PREFIX ::1:0:0:0:1/64
 ipv6 enable
 ipv6 nd other-config-flag
 no ipv6 redirects
 ipv6 dhcp server DHCP-PD
 ipv6 ospf 1 area 0
!
interface Dialer1
 mtu 1454
 ip address negotiated
 ip nat outside
 encapsulation ppp
 ip tcp adjust-mss 1414
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname XXXXXXXXXXXXXXXXX
 ppp chap password 0 XXXXXXXXXXXXX
 no cdp enable
!
router ospfv3 1
 router-id 1.1.1.1
 !
 address-family ipv6 unicast
  passive-interface default
  no passive-interface GigabitEthernet0/1
 exit-address-family
!
router ospf 1
 router-id 1.1.1.1
  passive-interface default
  no passive-interface GigabitEthernet0/1
 network 10.0.0.0 0.255.255.255 area 0
 network 172.16.0.0 0.15.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!

!
ip nat inside source static tcp 172.16.1.1 25 interface Dialer1 25
ip nat inside source static tcp 172.16.1.1 80 interface Dialer1 80
ip nat inside source static udp 172.16.1.1 53 interface Dialer1 53
ip nat inside source static tcp 172.16.2.1 443 interface Dialer1 443
ip nat inside source list PPPoE-local interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 172.16.3.1
!
ip access-list extended PPPoE-local
 permit ip host 172.16.1.1 any
 permit ip host 172.16.2.1 any
!

dialer-list 1 protocol ip list 1
!
route-map PPPoE permit 10
 match ip address PPPoE-local
 set default interface Dialer1

----------------------



0 件のコメント:

コメントを投稿